Breu ressenya del llibre “The Glass Cage: Automation and Us”, de Nicholas Carr

Fa un parell de setmanes vaig finalitzar el darrer llibre del crític tecnològic Nicholas Carr: “The Glass Cage: Automation and Us” i, des que l’he acabat de llegir, sento que es revela una sospita…

L’autor, que escrigué també com Internet ens impulsa a la infoxicació i a la superficialitat – fet que, per cert, interessa particularment a grans empreses com Google, Facebook o Twitter i a les elits governants), denuncia en aquest nou llibre com l’automatització creixent en moltes parcel·les ens estupiditza.

En el llibre il·lustra, entre d’altres camps, la tendència creixent en l’ús del pilot automàtic en l’aviació. Pel que sembla, els pilots d’avió d’avui dia utilitzen molt poc el pilot manual. En el camp de la informàtica és evident que cada vegada és més fàcil emprar aparells: fa unes dècades solament científics d’alt nivell utilitzaven computadores. Fa uns anys era necessària una mica de formació per a fer-ho. Ara, fins i tot les criatures de dotze mesos utilitzen l’iPad o el telèfons mòbils sense massa problemes.

Aquest fet, segons l’autor, té conseqüències importants i és que oblidem la pràctica i perdem la perícia que teníem en la utilització dels aparells “complicats” (ja siguin avions o ordinadors). L’ús dels entorns gràfics convertí en innecessària la línia de comandes. Els entorns gràfics de programació fan també el desenvolupament d’aplicacions més ràpid i senzill. Ara, quan puntualment escric un programa en C++, per exemple, escric el codi pràcticament sense ni pensar: sé que el compilador indicarà on són les meves errades i que provar el programa serà tant fàcil i ràpid que podré veure els errors quan provi el programa. Equivocar-se, en entorns virtuals, acostuma a tenir poques conseqüències.

En què converteix als humans l’ús de tecnologia cada vegada més avançada ? Als pilots d’avió en simple monitoritzadors d’indicadors lluminosos ?  Als informàtics en agents que fan clics sense cap dificultat ? Als metges ens persones que solament entren dades en sistemes experts i esperen resposta ?  Als arquitectes en tira-línies dins de pantalles ? O, en canvi, es tracta d’un pas essencial per a poder-nos dedicar a coses més avançades ? Però, si és així: en quines ?

Reflexionar de manera continuada i pausada des d’un punt de vista humanista sobre com la revolució tecnològica actual influeix en les nostres vides és imprescindible. Recomanable novament el llibre d’en Nicholas Carr.

Elaboración recursos didácticos asignatura “Seguridad Informática”

El pasado mes de noviembre me informaron desde el Ministerio que mi propuesta para la elaboración de recursos didácticos para la asignatura de Seguridad Informática (Ciclo formativo de grado medio en Sistemas Microinformáticos y redes) había sido aprobada.

Ahora dispongo de unos seis meses para la redacción y puesta en marcha de cursos en formato Moodle con contenido actualizado para esta asignatura para que puedan incorporarse en las plataformas de acceso público del Ministerio durante el próximo curso. Mi idea es añadir los programas y prácticas que utilizamos en las clases presenciales, entendiendo que se trata de aprender a desarrollar unas competencias de carácter práctico (y no en memorizar contenidos).

Por otra parte, me comprometí también en desarrollar todo el proyecto en abierto, para que cualquier interesado pueda husmear y chismear cuando quiera en todos los apuntes y recursos que vaya elaborando y publicando. Si hay algún interesado en mandarme recursos, prácticas de clase o nuevas ideas, no duden en escribirme.

Sitio web con los contenidos: http://seguridadinformatica.gerardfarras.com/

De la tecnologia com a motor de canvi en la història de la humanitat

Tractem en aquest apunt les característiques que ens fan humans i que ens separen de manera indubtable de la resta d’espècies del món animal. L’espècie humana actual té una capacitat intel·lectual així com un modus vivendi molt més sofisticat que la resta d’espècies. Som animals socials i culturals molt allunyats de la resta de mamífers. És possible però trobar el detonant que atorgà aquesta diferenciació a l’homo sapiens sapiens?

La tecnologia com a camí de no retorn. No fou pas l’ús de les primeres eines lítiques el que ens diferencià primerament com a éssers humans i és que d’altres espècies d’homínids en el passat foren capaces de tasques similars. Malgrat això, la creació i ús d’aquesta primera tecnologia rudimentària marcà un camí de no-retorn. De totes maneres, no és possible afirmar que sigui l’eina el que ens fa humans.

Què és un ésser humà? Som l’única espècie viva del clan homínid, una branca de primats caracteritzats per una postura erecta i locomoció pedestre, amb gran capacitat manual i ús de tecnologia i una tendència cap a cervells i societats més complexes. L’enorme capacitat de supervivència i d’adaptació al medi de l’ésser humà han permès que aquest es reproduís i visqués en entorns realment inhòspits: des de deserts i glaceres polars a…. l’espai.

L’avantatge principal que permet explicar aquest èxit evolutiu és a causa del fet de disposar d’un gran cervell amb un neocòrtex desenvolupat i que habilita alts nivells de raonament abstracte, llenguatge, resolució de problemes, socialització i cultura a través de mecanismes d’educació social. Som l’única espècie actual que sap fer foc, cuina i es vesteix. Els humans som únics en l’ús de comunicació simbòlica a través del llenguatge i l’art per l’intercanvi d’idees i d’organització.

De la consciència religiosa. Potser fou el naixement de la consciència i d’un sentiment pseudoreligiós la característica que ens convertí definitivament en el que som. La qüestió plenament humana sobre el misteri de la vida, del perquè de l’existència, d’on venim i on anem, preguntes plenament vigents i de les quals potser mai obtindrem resposta. També d’una inherent necessitat existencial de transcendència.

Es tracta del concepte d’Homo religiosus apadrinat i defensat per tota una sèrie de filòsofs i científics de primera línia com foren Hegel (1770-1831), Kierkegaard (1813-1855), Mircea Eliade (1907-1986) o Erich Fromm (1900-1980) que consideren que l’existència humana és bàsicament religiosa, independentment del credo particular. Fins i tot els humanistes que es declaren plenament ateus senten aquesta necessitat existencial de transcendència a partir de l’amor a la humanitat, a les futures generacions i la mateixa natura.  Probablement és aquest el tret que millor ens diferencia de la resta d’espècies del món animal. Hi ha fins i tot una hipòtesi que defensa que estem dissenyats genèticament per a tenir religió. Si considerar que l’existència d’un Déu superior ha estat un recurs útil per la supervivència i el benestar humà durant generacions, aquesta tendència a la religió es podria haver incorporat en el nostre propi ADN.

Com aparegué però aquesta consciència? Quin és el suport físic que permeté desenvolupar-la? Aparegué de manera fortuïta a través de mutacions genètiques? Intentarem tractar aquest apunt en el següent apartat.

Qüestió de supervivència i adaptació al medi. No considerem pas que l’evolució humana aparegués de manera fortuïta, sinó que sorgí, com ha passat amb la resta d’espècies, per un procés d’especiació basat en la selecció natural i la deriva genètica. En el cas humà, la forçada adaptació al medi causada per canvis climàtics fou un factor definitiu. L’hàbitat el qual acollia l’homínid pacífic i tranquil que es dedicava a recol·lectar fruïts i d’altres vegetals fou seriosament compromès i l’obligà a la lluita per la supervivència en un entorn molt més hostil: la sabana africana; un espai més obert, amb menys refugis, menys vegetals i, sobretot, amb molts altres animals.

Fou en aquest nou i violent entorn el qual l’homínid primitiu hagué d’afrontar la seva pròpia supervivència. La carronya es convertí en una part important de la seva alimentació, malgrat que també ho era de molts altres depredadors molt més temibles. Però, tal com diu el proverbi espanyol: “el hambre agudiza el ingenio”. Aquests protohumans començaren a emprar eines per a accedir a l’interior dels ossos, on els teixits de la medul·la òssia romanien inaccessibles a la resta d’animals.

En aquest procés d’adaptació al medi fou, probablement, on neix l’ésser humà i és que tota una sèrie d’esdeveniments impulsen una espiral de canvi: eines lítiques (primera tecnologia) per accedir a una nova alimentació (amb més proteïna animal) que, de retruc, promouen més massa encefàlica i més capacitat intel·lectual i, d’aquí, a tecnologia més sofisticada. I així nasqué una espiral tecnològica que ha estat inherent a la història humana. Tecnologia més sofisticada que permeté més efectivitat en la recerca de menjar. Més efectivitat que permeté “alliberar” de la tasca a alguns membres del grup, que pogueren dedicar-se a elaborar d’altres tasques (per exemple, la recol·lecció), fet que originà una primera societat organitzada, més complexa que l’anterior, completament diferent de com havia actuat l’homo simiesc fins aleshores.

Aquest és, segons el meu parer, una característica que sí que és plenament humana: la d’un ús cada vegada més sofisticat de nova tecnologia, gràcies a més massa encefàlica i que, de retruc, permet ments i societats cada vegada més complexes. El procés evolutiu continua.

Configuració router VDSL CISCO887VA-K9 amb Movistar

Instruccions per a configurar un router Cisco 887-K amb una VDSL de Movistar:

controller VDSL 0
!
interface Ethernet0
description VDSL-MOVISTAR
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
no ip address
shutdown

interface FastEthernet1
 no ip address
 !
 interface FastEthernet2
 no ip address
 shutdown
 !
 interface FastEthernet3
 no ip address
 shutdown
 !
 interface Vlan1
 ip address 192.168.0.11 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 !
 interface Dialer0
 ip address negotiated
 no ip redirects
 no ip proxy-arp
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp authentication pap callin
 ppp pap sent-username adslppp@telefonicanetpa password 0 adslppp
 ppp ipcp route default
 no cdp enable
 !
 ip forward-protocol nd
 !
 ip nat inside source list 10 interface Dialer0 overload
 ip route 0.0.0.0 0.0.0.0 Dialer0
 !
 access-list 10 permit 192.168.0.0 0.0.0.255
 !

 

 

Sistema de watermarking emprant els bits menys significatius

Comento en aquest apunt un sistema de watermarking emprant una tècnica senzilla. Del que es tracta és “d’amagar” una imatge en una altra.

Aquesta és la imatge original:

tiger

 

 

 

 

 

 

 

I aquesta és la imatge que volem “amagar” en l’anterior:

marca

 

 

 

 

 

 

 

La idea del programa és obviar els 3 bits de menys pes de cada píxel de la imatge original i substituir-los pels 3 bits de més pes de la imatge que volem amagar.

Aquest és el codi en Python:

 

import Image
import os

im = Image.open(“tiger.jpg”)
marca = Image.open(“marca.jpg”)

pixels = im.load()
width, height = im.size

marcapixels = marca.load()

msb = Image.new(“L”, (width, height))
msbpixels = msb.load()

for x in range(width):
    for y in range(height):
        cpixel = pixels[x, y]
    mpixel = marcapixels[x, y]
    a = (mpixel & 224) >> 5
    msbpixels[x,y] = (cpixel & 248) + a

msb.save(“tigerwithmark.jpg”, “JPEG”, quality=100)

 

Executant aquest programa obtenim una imatge molt similar a l’original, però que ja conté la marca:

tigerwithmark

 

 

 

 

 

 

 

Ara, emprant aquest altre programa, podríem extreure la marca:

import Image
import os

im = Image.open(“tigerwithmark.jpg”)
pixels = im.load()
width, height = im.size

msb = Image.new(“L”, (width, height))
msbpixels = msb.load()

for x in range(width):
    for y in range(height):
        cpixel = pixels[x, y]
    a = (cpixel & 7) << 5
    msbpixels[x,y] = a

msb.save(“extractmark.jpg”, “JPEG”, quality=100)

extractmark

 

 

 

 

 

 

 

Aquesta darrera imatge ha perdut qualitat, però recordem que solament vàrem agafar els tres bits més significatius de la imatge original!

 

Del com les xarxes socials influeixen en la percepció de la nostra vida

Molt interessant aquest video per a reflexionar sobre com les xarxes socials poden influir en la percepció de la nostra vida.

What’s on your mind? from Shaun Higton on Vimeo.

Fa uns anys, quan Internet era una xarxa per experts i eines com Facebook no existien, podia comparar la meva vida amb la dels meus veïns i amics (que no acostumava a ser massa diferent de la meva). Ara, en canvi, centenars de contactes més o menys coneguts/desconeguts em mostren fotografies dels seus viatges més exòtics i les seves vides tant felices.

Facebook tendeix a fer-nos comparar la nostra vida amb la dels altres ? Això no és font segura de depressió ?

Breu ressenya de “The Zero Marginal Cost Society”

Escric en aquest apunt una breu ressenya del darrer llibre que he llegit : “The Zero Marginal Cost Society : the Internet of things, the collaborative commons, and the eclipse of capitalism” d’en Jeremy Rifkin.

L’autor parteix de la premisa que el sistema capitalista, en batalla permanent en els mercats, innova de manera constant amb l’objectiu de rebaixar el cost dels productes i serveis. En alguns casos ha aconseguit que el cost marginal (el que costa produir una unitat més) sigui zero. Les produccions culturals en format digital en són bons exemples : fer còpies a partir d’un original té un cost nul. Rikfin exposa altres exemples : els MOOCS en el sistema educatiu, les impressores 3D (que permetran imprimir objectes des de casa o fablabs a cost zero), l’energia (a partir d’una xarxa distribuïda de generació elèctrica basada en renovables. Recordar el llibre també del mateix autor: “The Third Industrial Revolution“) i, en general, una Internet of Things que permetrà compartir tota mena de recursos entre usuaris. AirBNB i Uber són dues aplicacions recents d’aquesta idea de compartir en una Internet of Things. No m’estranya gens que els hotels i els taxistes es queixin : les xifres d’ambdues companyies poden fer empal·lidir fins i tot al més gran.

Rifkin considera l’adveniment d’una economia basada en la col·laboració dels individus (collaborative commons) que serà el principi de la fi del sistema capitalista actual : si els individus es dediquen més a compartir que a comprar i disposen d’un seguit d’importants elements gratuïts (educació, energia, fabricació pròpia), això propicia l’eclipse del capitalisme (the eclipse of capitalism) (i, de retruc, la fi del treball).

Tot plegat inspirat en una nova consciència planetària que acompanyarà i fomentarà aquest canvi : una nova consciència més empàtica i humana, basada en la inclusió i no en l’exclusió, sostenible, on s’atorga més importància a l’accés a noves xarxes i a noves experiències que no en la possessió i acumulació de riquesa (recordar el llibre també del mateix autor: “The empathic civilization“).

Rifkin dilucida perfectament i amb optimisme un futur agradable i sostenible, on la gent pot dedicar-se a la cultura, l’art i la ciència i s’allibera de multitud d’obligacions. Malgrat hi ha multitud d’obstacles, crec que Rifkin indica el camí correcte, malgrat serà tortuós.

Afegeixo un parell de videos. En el primer el concepte optimista d’una civilització més empàtica. En el segon, l’explicació que fa el mateix autor sobre The Zero Marginal Cost society a la seu de Google:

Petit assaig sobre la globalització cultural

Sobre com la globalització afecta les identitats i els referents culturals de la població mundial. Per una banda, es confirma la temuda uniformització en l’estil de vida i els “habitus” personals: ja no és possible viure al marge del mercat en aquest món globalitzat. Per tal de reeixir en la subsistència els humans hem de participar en el mercat econòmic global, tant pel que fa al consum de productes com per vendre la nostra força laboral. D’altra banda però, el traspàs d’enormes fluxos d’informació carregats de referents culturals atorga la possibilitat d’adquirir personalitats pròpies altament individualitzades totalment desconegudes en temps passats.

Read More

M6. UF2. Configuració d’un RAID 0 amb Windows 7 i Virtual Box

Algunes anotacions en aquest apunt per a configurar un RAID 0 en un entorn Windows 7 emprant el programa Virtual Box.

Per aquest exemple, la configuració dels discs de la màquina virtual serà la següent:

raidwin0

 

Considerem que tenim instal·lat el sistema operatiu en el primer disc i que, els altres dos estan lliures per a configurar el RAID. Ara, des de l’opció “Computer”, botó de la dreta “Manage”, accedirem al gestor de discs.

 

raidwin1

i, simplement seguint l’assistent:

 

raidwin2

fins que obtinguem el nou volum.

 

raidwin3

 

Fixem-nos que aquest darrer volum té la capacitat de la suma dels dos discs escollits.

 

M6. UF2. Carpeta compartida de Windows via FreeNAS

Alguns apunts respecte a com configurar un recurs compartit Windows emprant la distribució FreeNAS i VirtualBox.

El primer pas consisteix en configurar la màquina virtual. S’ha d’establir BSD i FreeBSD. La configuració dels discs és la següent:

freenas1

La configuració de la xarxa ha de ser “Adaptador pont”.

Procedim amb la instal·lació habitual, retirem el CD i arranquem la màquina. Apareixerà això:

freenas2

Ara, obrim el navegador web en el sistema operatiu host i apuntem a l’adreça indicada. En aquest cas: http://192.168.1.140.

freenas3

El proper pas serà crear un RAID-1 en format ZFS emprant els dos discs virtuals connectats al Virtual Box.

Volumes –> ZFS Volume manager

freenas4

 

Amb el volum construït, generarem un recurs compartit:

Sharing -> Windows (CIFS) shares –> Add Windows CIFS share

 

freenas5a

 

Ara, si ho hem fet tot correctament, tindrem disponible un recurs compartit accessible via xarxa (en aquest cas \\192.168.1.140):

freenas5